イナヅマTVログ

Apache Flex SDK Installer

[メモ] FB 4.7, AIR SDK を3.7へアップデート

| 0件のコメント

Flash Builder 4.7を使い始めました。
諸事情でFlash Builder 4.6を使ってたけど、やっと4.7。
AIR for iOSで実機インストールまでのメモ。

えっと、FB 4.7自体の登場は1年も前なのでなんの役にも立たないオレメモです。

Flex SDKを4.9.1へ

Flex SDKのインストールはApache Flex SDK Installerのおかげで超簡単です。
Apacheエライ!
Apache Flex SDK Installer

AIR SDKをアップデート

改良なのか、改悪なのか分からないけど、AIR SDKをFlex SDKにマージするのでは無くApplication Flash Builder pluginsフォルダのAIRSDKを指定して使うようになっていました。
FlexをApacheに寄贈しAIRだけAdobeが開発するようになったからかな。

/Applications/Adobe\ Flash\ Builder\ 4.7/eclipse/plugins/com.adobe.flash.compiler_4.7.0.349722/AIRSDK

FB環境設定「アップデートの有無をチェック…」をクリックしてもアップデートされません。
なんだよー
しょうが無いので手動でアップデート。

– AIRSDK フォルダへ AdobeAIRSDK.tbz2 をコピー。
– ターミナルを起動しAIRSDKへ移動
– 解凍しマージ

cd /Applications/Adobe Flash Builder 4.7/eclipse/plugins/com.adobe.flash.compiler_4.7.0.349722/AIRSDK
sudo tar jxvf AdobeAIRSDK.tbz2

AIR SDKを複数用意して切り換えて使うには、いちいちコノAIRSDKを手動で差し替えないといけない様子。
頭悪すぎ…

証明書(.p12)とかプロビジョニング(.mobileprovision)を設定したら、実機でデバッグできるようになりました。
適当にカンでマージコピーしたのでSDKアップグレード方法自体が間違ってる可能性大だけど、アプリ作れたからいいんかな。

【パスワード無しの証明書】
証明書をパスワード無しで作ってたら、空のままENTERしても認識してくれなかったけど気のせいかしら。
パスワード付きの証明書に変えました。

【公式情報】
helpx.adobe.com
Flash Builder Help /
Update the AIR SDK for ActionScript Projects | Flash Builder 4.7

公式情報があった。
けど…
AIRSDK_Compiler.tbz2 ってなに?

【Adobeさんへお願い】
なんで自社製品のSDKアップデートがこんなに手間かかるの?
もうちょっと手軽にできるようにして欲しい。
クリック一発でできて当たり前だと思うんだけどさ。

それと、AIR for アプリの設定をいつまでXMLを直接編集させる気なんやろ…
FDTはGUI設定できる機能あるのに。

コメントを残す

必須欄は * がついています